Commit 046175da authored by Andrew Morgan's avatar Andrew Morgan
Browse files

Merge branch 'release-v1.32.1' of github.com:matrix-org/synapse

parents a0972085 0c23aa39
...@@ -2,10 +2,10 @@ Synapse 1.32.1 (2021-04-21) ...@@ -2,10 +2,10 @@ Synapse 1.32.1 (2021-04-21)
=========================== ===========================
   
This release fixes [a regression](https://github.com/matrix-org/synapse/issues/9853) This release fixes [a regression](https://github.com/matrix-org/synapse/issues/9853)
in Synapse 1.32.0 that caused connected Prometheus instances to become unstable. If you in Synapse 1.32.0 that caused connected Prometheus instances to become unstable.
ran Synapse 1.32.0 with Prometheus metrics, first upgrade to Synapse 1.32.1 and follow
[these instructions](https://github.com/matrix-org/synapse/pull/9854#issuecomment-823472183) However, as this release is still subject to the `LoggingContext` change in 1.32.0,
to clean up any excess writeahead logs. it is recommended to remain on or downgrade to 1.31.0.
   
Bugfixes Bugfixes
-------- --------
...@@ -18,7 +18,14 @@ Synapse 1.32.0 (2021-04-20) ...@@ -18,7 +18,14 @@ Synapse 1.32.0 (2021-04-20)
   
**Note:** This release introduces [a regression](https://github.com/matrix-org/synapse/issues/9853) **Note:** This release introduces [a regression](https://github.com/matrix-org/synapse/issues/9853)
that can overwhelm connected Prometheus instances. This issue was not present in that can overwhelm connected Prometheus instances. This issue was not present in
1.32.0rc1, and is fixed in 1.32.1. See the changelog for 1.32.1 above for more information. 1.32.0rc1. If affected, it is recommended to downgrade to 1.31.0 in the meantime, and
follow [these instructions](https://github.com/matrix-org/synapse/pull/9854#issuecomment-823472183)
to clean up any excess writeahead logs.
**Note:** This release also mistakenly included a change that may affected Synapse
modules that import `synapse.logging.context.LoggingContext`, such as
[synapse-s3-storage-provider](https://github.com/matrix-org/synapse-s3-storage-provider).
This will be fixed in a later Synapse version.
   
**Note:** This release requires Python 3.6+ and Postgres 9.6+ or SQLite 3.22+. **Note:** This release requires Python 3.6+ and Postgres 9.6+ or SQLite 3.22+.
   
......
...@@ -93,11 +93,11 @@ Regression causing connected Prometheus instances to become overwhelmed ...@@ -93,11 +93,11 @@ Regression causing connected Prometheus instances to become overwhelmed
This release introduces `a regression <https://github.com/matrix-org/synapse/issues/9853>`_ This release introduces `a regression <https://github.com/matrix-org/synapse/issues/9853>`_
that can overwhelm connected Prometheus instances. This issue is not present in that can overwhelm connected Prometheus instances. This issue is not present in
Synapse v1.32.0rc1, and is fixed in Synapse v1.32.1. Synapse v1.32.0rc1.
If you have been affected, please first upgrade to a more recent Synapse version. If you have been affected, please downgrade to 1.31.0. You then may need to
You then may need to remove excess writeahead logs in order for Prometheus to recover. remove excess writeahead logs in order for Prometheus to recover. Instructions
Instructions for doing so are provided for doing so are provided
`here <https://github.com/matrix-org/synapse/pull/9854#issuecomment-823472183>`_. `here <https://github.com/matrix-org/synapse/pull/9854#issuecomment-823472183>`_.
Dropping support for old Python, Postgres and SQLite versions Dropping support for old Python, Postgres and SQLite versions
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment